Jump to content

Using different GAME + patch dumps (Remarry dumps)

Recommended Posts

If you've downloaded Game and Game update from two different sources (Base Game dumped by someone and Patch dumped by someone else, using his own copy of a game) you'll have to re-marry the two of them. This is because they both will have different digest. Otherwise your Game Update installation will error out.

Tutorial found on psxhax forums, all credit goes to Sashka. GTA V Update used as an example:


1) Create CUSA00419-patch folder
2) Extract all files and directories of UP1004-CUSA00419_00-GTAVDIGITALDOWNL-A0121-V0100.pkg with orbis-pub-chk in CUSA00419-patch folder (passcode is 00000000000000000000000000000000)
3) Delete UP1004-CUSA00419_00-GTAVDIGITALDOWNL-A0121-V0100.pkg
4) Move all the content in CUSA00419-patch/Sc0/ to CUSA00419-patch/Image0/sce_sys/
5) Delete Sc0 folder
6) Move playgo-chunk.dat from CUSA00419-patch/Image0/sce_sys/app/ to CUSA00419-patch/Image0/sce_sys/ and overwrite it
7) Delete app folder
8) Move all the content in CUSA00419-patch/Image0/ to CUSA00419-patch/
9) Delete Image0 folder
10) Create gp4 of CUSA00419-patch folder with gengp4 v1.7 and save it
11) Open CUSA00419-patch.gp4 with orbis-pub-gen, go to Command->Project Setting->Patch and look at Application package:
12a) If you see (Package Digest: XXXXXXXXXXX...), click OK
12b) If you see (Image is not valid), click Select, go to the folder where UP1004-CUSA00419_00-GTAVDIGITALDOWNL-A0100-V0100.pkg is and open it, click OK
13) Go to Command->Build Image->Select Output Path->Build
14) Done :)

Try it!



  • Like 1
Link to comment
Share on other sites

Worked fine for me. Thanks for the tips. Keep in mind that the dump needs to have the 00000000000000000000000000000000 , i run into some update dumps that for whatever reason had different one.  Here is a quick video of the whole process


  • Upvote 1
Link to comment
Share on other sites

Hi, i'm getting an error when rebuilding.. 


[Debug]    2018-06-05 16:30:27 Create image Process started.
[Error]    Format of the param file is not valid. (sce_sys/param.sfo, unexpected Application Version (APP_VER))
[Warn]    The required file is missing (sce_sys/changeinfo/changeinfo.xml). The created package will not be imported into GEMS.
[Debug]    nptitle.dat: NP Title file.
[Error]    2018-06-05 16:30:28 Create image Process finished with error(s).

edit: figured out the problem, had to hex edit param.sfo from 1.00 to the patch ver.

Edited by SneakyDelphox
Link to comment
Share on other sites

i've just tried to do this with UP0082-CUSA04551_00-ANDROIDS20030612-A0106-V0100.pkg (NieR - Automata) and it says password missmatch



guess you can't unpack retail updates :(

Edited by RazorX
Link to comment
Share on other sites

  • 2 weeks later...


This is a bit long so please bear with me :)

I have a question about repacking/remarrying updates to another base, so far i followed the procedure above "by the letter" and all of them worked perfectly for me, i did this on Kingdom Hearts 2.8 HD, The Last Guardian, The Last of Us Remastered, Gravity Rush 2 and other games, but there is one instance where this procedure did not work as it should, i thought it was because i was using an outdated tool or it was something else entirely, yet i tried combinations of the tools from gengp4 v1.7.2,  gengp4 v1.8, Fake PKG Generator (pre-3.12 release, i forgot what ver. this is), Fake PKG Generator 3.12 hotfix2 & Fake PKG Generator 3.38, the game in question is:

Base: Mafia III (CUSA03617); md5 - 981dbff4027c99d1f5d085c3fa5928c3
Update : Mafia III Update 1.09 (CUSA03617); md5 - 144d1b6dc7dae206a7429730159e601f

If you do the procedure in this topic then run this game, it will result in an infinite "0% Installation" screen, i waited 30 mins to see if it's just slow and it's still at 0%, i tried this on all the available tools and the result was the same as well, then i stumbled upon a slightly different method, which is the same but it leaves out 2 of the steps:

6) Move playgo-chunk.dat from CUSA00419-patch/Image0/sce_sys/app/ to CUSA00419-patch/Image0/sce_sys/ and overwrite it
7) Delete app folder

The procedure i used did not use steps 6 & 7, it was a gamble and i was running out of options so i did it anyway, then to my surprise, the game (Mafia III with the remarried update 1.09) finally worked, it did not even go througn the installation screen, it just went forward to the main menu and the DLC that was only supposed to work for update 1.09 worked as well :)

So the question is, is steps 6 & 7 really needed?, or is this an isolated/special case where not moving the "playgo-chunk.dat" is necessary to make this proper remarried update?


Edited by megumin
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...