Jump to content

VitaShell blank template temp fix


Recommended Posts

Ok so if your on 3.65 変革 ◯ and you had VitaShell installed but don't anymore probable due to a corrupted memory card and now when you try installing VitaShell (any version) you get a error and then you find vita sos doesn't actually do anything then this may help.

Well first of if you can still install vpk files you should install a vpk installer that's not VitaShell (for some reason VitaShell has issues with installing it's self now) i would suggest this as that's what i did all my testing on
Please login or register to see this link.

Now that you have that installed you can use app manager to install the blank
Please login or register to see this link.
 

Once you have the blank installed you can use the blank or do it manually but you should do a cold reboot
When the vita has finished rebooting you can now use app manager to install VitaShell 1.9 or higher over top of the blank and that should work find

This is kinda a round abort temp fix but it will work for now. as soon as i work out code for installing vpk files all you will have to do to reinstall VitaShell is replace any eboot.bin with the installer i'm working on

Some extra side notes:
so yeah as i said i only built this because 2 days into running 3.65 変革 ◯ my memory card shat itself again and i had to reformat it losing VitaShell i had MoluclerShell backed up to the system so i worked from there

i have a few ideas on why VitaShell isent installing
1. 3.65 変革 ◯ as a issue with the VitaShell eboot.bin and its super wired its ever VitaShell i tested (i tested abort 6)
2. VitaShell has issues with installing itself over top of its self. it kinda makes sence when you think abort it but i swear you could do it befoul
3. There seams to be a conflict of sorts with VitaShell cache files and other livearea data left over from 3.60 and don't seem to be compatible with 3.65

here probably isn't the best spot to post this but i don't really have a account anywhere else in vita community so this will have to do.

Oh yeah i almost forgot i couldent test this 100% as it seems the issue with VitaShell not install is a once of once you fix the install you can remove and reinstall VitaShell with out any issues so i think the issue people are having is left over system data from 3.60.
yes i tried deleting ux0:VitaShell and i would suggest that but that dosent fix the not being able to install VitaShell error on it's own

Edited by MobCat
  • Like 1
  • Upvote 2
Link to post
Share on other sites
9 hours ago, Ravenstorm said:

I have this very problem with a dead memory card on my PSTV, no one seemed to know how to fix it though. The firmware is 3.65, but the memory card is unusable and therefore has no Vitashell at all so I can't install VPKs. So far no one seems to know a way to save it.

yeah mine was dying in 3.60 and upgrading to 3.65 dident help it any...
It be grate if when you installed 3.65 変革 ◯ the firmware update thingy would install VitaShell as a system app like all the default apps like the PSN. It add custom suprx for enso so i cant see what it cant install a system app....
Actual a app that installs VitaShell as a system app is some i should be trying to work on instead. Yes i know HBinjector is a thing but that only replaces a eboot.bin of a system app not installs a now one (and i found with HPinjector if you inject into something like the calendar that has its own suprx it conflicts with VitaShell making VitaShell crash a bunch)
Well this temp vpk i made should work if you can get access to ftp on your vita and there is a bunch of ways to do that like eg. make any LUA player app crash
once you have that you can use that to replace the eboot.bin of any app with VitaShell's eboot.bin then use this temp VitaShell to install App Manager then use the ftp server in App Manager to fix the eboot.bin you replace for the temp VitaShell then use App Manager install the blank VitaShell i made then cold reboot the vita and use App Manager again to install VitaShell over top of the blank. Its super ass up and a pain but it seams to work if you can get accuses to ftp and once you do this once and fix the 3.60 to 3.65 memory card issue you only have to do this once.

  • Like 1
  • Upvote 1
Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Similar Content

    • By Bloodmoon10756
      Okay, so, when setting up the system and microsd card for the vita you have to add the gamesd.skprx to ur0:tai as ur0:tai/gamesd.skprx, right? Well, for some reason the skprx is disappearing and I dont know what to do about it!!! I need the file to mount my sd2vita to my system, but it's not staying at all. Everything is done correctly as well.
    • By BMT-Jamie
      Update v1.6

       
      # Added Translation ENGLISH (Special thanks CelesteBlue) (Continued strong demand on TW of the community to the EN version) # Interface Selecting the language in the MEMU # Saving the language in the first configuration in "Langage.conf" # Added support for 3 wallpapers # Change interface for wallpaper DRAG AND DROP # Removed the bar "Browse" which became useless # Fixed minor bug  
      Please login or register to see this link.
       
      CREDITS TO ALL RESPECTFUL OWNERS
    • By BMT-Jamie
      Please login or register to see this link.
      How to install ? (On top of default VitaShell)
      Download NeonRift.zip from the link below.
      Copy the ‘NeonRift’ folder inside the downloaded zip to ux0:VitaShell/theme/
      Switch to NeonRift theme from VitaShell settings. Restart VitaShell. Enjoy.
      (Optional) If you would like to install the LiveArea theme, bubble and Boot Screen (which I recommend), just copy the ‘VITASHELL’ folder to ur0:appmeta/ and ux0:app/ and make sure to confirm any overwrite.
       
      All Credits To Respectfull Owners
×
×
  • Create New...